Обновление с debian wheezy до jessie

Автор: | 01.06.2019
Advertisements

В связи с полным прекращение поддержки debian wheezy пришла пора обновиться до следующей поддерживаемой версии wheezy.

Для обновления необходимо в файле /etc/apt/sources.list заменить строки  на:

Далее последовательно выполнить команды для обновления:

Особенности обновления:

  • Необходимо прочитать и согласиться с текстами обновлений, для выхода из режима чтения нажать q
  • Внимательно прочитать заменять ли конфигурации, если были изменения
  • Самое важное, если есть только суперпользователь root, то для него предлагается отключить пароль. Если другого пользователя нет, то соглашаться не всегда стоит, особенно когда подключение есть только через ssh.

PHP, MySQL, Python — серьезных изменений по совместимости нет.

Apache2.2 обновляется до 2.4, соответственно в конфигах нужно разрешить доступ (Require all granted), исправить нужно будет в каждом файле.